Back to overview
Resolved
MaxBonding Node Down
Aug 20, 2026 at 10:41pm UTC
Affected services
London DC
Resolved
Aug 21, 2026 at 12:08am UTC
Issue Resolved
Affected services
Created
Aug 20, 2026 at 10:41pm UTC
Users unable to connect to the London MaxBonding Node.
Affected services